Search fixed

I finally figured out what the problem was with the search feature and permalink problem. Clicking on the title of any post should take you to its permalink and comments page (each post has its own page). This wasn’t happening. Anyway, it turns out that though some posts were labeled as “published” the “status” was unpublished.

The problem now is that this has to be corrected manually,… post by post. I’m working my way backward to 2004. I’m about halfway finished. 8)

New theme installed

The Deserta theme is now installed and it appears to be very clean (visibly and as far as code is concerned).

The Deserta theme is now installed and it appears to be very clean (visibly and as far as code is concerned). I think the problem I was having with the search function may be fixed now. Before, if you did a search, whether using the search function or the comments or tags or any mechanism for looking at past posts, on occasion, you would get a 404 error message. There didn’t seem to be any rhyme or reason for it. If I refreshed the permalinks sometimes it would fix it and sometimes it wouldn’t. I think it had something to do with the way the Default theme is written. All of that is to say, if anyone has a problem retrieving past posts or get a 404 error code, let me know.

Meanwhile, it is good bye to the Default theme… it served well.

UPDATE RE: Searching

Searching, I have discovered, works perfectly well for the first item but if you need to see the comments (for example) of that posts you have to be registered.  Only registered users can go past one search.

Here’s an example to try.  Type the word Sicko in the search box.  You’ll get all the posts containing that word. Go to the post labeled Sicko 2 and click on comments. If you are registered, you’ll see those comments, otherwise you won’t.

I’ll make a note on the About page.